Wie kann ich über ein DSL Router auf ein FTP Server zugreifen

#0
05.10.2003, 15:57
...neu hier

Beiträge: 5
#1 Hallo
ich habe folgendes Problem wenn ich mich auf ein Privaten FTP Server einloggen will den ein Freund von mir betreibt kommt immer folgendes, das das soweit richtig ist weiß ich aber er zeigt mir am ende immer ne Fehler meldung an.

Ich gehe über den Allnet ALL1295 DSL Router ins Internet und um auf den Server zu kommen benutze ich CuteFTP. Bevor ich jedoch den Router hatte kam ich immer ohne Probleme drauf.

Kann mir einer einen Rat geben woran es liegen könnte!!! Das problem hab ich übrigens bei jedem FTP Server!

Vielen Vielen Dank im Voraus

STATUS:> Verbinden:
STATUS:> Verbindungsherstellung zuxx.xxx.xxx.xx
STATUS:> Verbindungsherstellung zuxx.xxx.xxx.xx (ip = xx.xxx.xxx.xx)
STATUS:> Socket verbunden. Warten auf Begrüßungsmeldung...
220---------- Herzlich willkommen auf xxxx-xxxx ----------
220-Sie sind Benutzer 2 von 50 erlaubten.
220-Lokale Zeit: xx:xx. Serverport: xxxx.
220-Dies ist ein privates System - Keine anonyme Anmeldung möglich.
220-Dieser Server unterstützt FXP.
220 Sie werden nach 15 Minuten Inaktivität getrennt.
STATUS:> Verbunden. Authentifizierung...
BEFEHL:> USER xxxxxxxxxx
331 Benutzer xxxxxxxxxOK. Paßwort erforderlich.
BEFEHL:> PASS xxxxxxxx
230-Benutzer xxxxxxxxxx hat Gruppenzugang zu: xxxxx
230 OK. Aktuelles Verzeichnis ist /.
STATUS:> Anmeldung erfolgreich
BEFEHL:> TYPE I
200 TYPE ist jetzt 8-bit binary
BEFEHL:> pwd
257 "/" ist das aktuelle Verzeichnis.
BEFEHL:> TYPE A
200 TYPE ist jetzt ASCII
STATUS:> Verzeichnisliste wird geladen...
BEFEHL:> PORT xxx,xxx,x,x,xx,xxx
200-FXP-Transfer: von xxx.xxx.xxx.xxx to xxx.xxx.x.x.
200 PORT-Kommando erfolgreich.
BEFEHL:> LIST
FEHLER:> Zeitüberschreitung
BEFEHL:> TYPE I
425 Kann keine Datenverbindung zu Port xxxx aufbauen.: Connection timed out
STATUS:> Unidentifizierbare Antwort empfangen
200 TYPE ist jetzt 8-bit binary
Dieser Beitrag wurde am 05.10.2003 um 16:01 Uhr von KaddiMen editiert.
Seitenanfang Seitenende
05.10.2003, 16:19
...neu hier

Beiträge: 7
#2 Ich kann Dir zwar (noch) nicht helfen, aber habe das gleiche Problem:

http://board.protecus.de/t6487.htm

Ich dachte zunächst auch, es läge an jedem FTP-Server, aber einige funktionieren, andere nicht! Probier doch mal ftp.microsoft.com - würde mich interessieren... denn der geht bei mir (im Gegensatz) zu sehr vielen anderen.
Dieser Beitrag wurde am 05.10.2003 um 16:21 Uhr von marcusb editiert.
Seitenanfang Seitenende
05.10.2003, 16:46
Member
Avatar Xeper

Beiträge: 5289
#3 http://board.protecus.de/t4580.htm

Ich kapier nicht warum es diese Probleme immer noch gibt, das müßte jetz wirklich jeder gecheckt haben ;)
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
05.10.2003, 16:52
...neu hier

Themenstarter

Beiträge: 5
#4 Hey Xepter wenn es wirklich jeder gecheckt haben müsste, dann kannste ja nochmal erklären was man machen muss damit man wieder auf FTP Servern zugreifen kann!!!!
Seitenanfang Seitenende
05.10.2003, 16:58
Member
Avatar Xeper

Beiträge: 5289
#5 @KaddiMen

Nein - ehrlichgesagt hatten wir das Problem mit active Ftp. und Passive Ftp. so oft in allen variationen - vielleicht suchst du mal mit der Suchfunktion dieses Boards.
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
05.10.2003, 17:03
...neu hier

Themenstarter

Beiträge: 5
#6 Weiss meinst du was ich denn alles schon gemacht hab. Selbstverständlich hab ich hier im Forum schon geguckt bevor ich den neuen Thread gemacht hab.
Aber anscheinend haben immernoch mehrere Leute das Problem!!!!

Kannste es wirklich nicht nochmal erklären wäre sehr dankbar!!!!
Seitenanfang Seitenende
05.10.2003, 17:07
Member
Avatar Xeper

Beiträge: 5289
#7 http://board.protecus.de/t512.htm

Haste das au scho gelesen?
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
05.10.2003, 17:11
...neu hier

Themenstarter

Beiträge: 5
#8 Ja hab ich schon gelesen. Der will sich aber ein FTP selber basteln, ich hingegen möchte auf einen vorhandenen FTP Server zugreifen!!!!!
Seitenanfang Seitenende
05.10.2003, 17:45
...neu hier

Themenstarter

Beiträge: 5
#9 Hey wenn jemand Rat weiss bitte Posten brauch super dringend Hilfe!!!

Danke!
Seitenanfang Seitenende
05.10.2003, 18:06
Member
Avatar Xeper

Beiträge: 5289
#10 @kaddiMen

Das ist aber das selbe Problem es geht sich um passive und active ftp und darum das wenn du ein router hast nicht auf alle seiten zugreifen kannst weil bei active ftp der server die verbindung herstellt von port tcp/20(ftp-data) zu einem highport auf deinem client dies ist nicht möglich weil der Router dazwischen liegt, dafür gibts passive ftp. Bei passive ftp stellt der Client die Verbindung zum Server her. Jetz kappiert? Ansonsten geh mal auf www.lan4me.de da wird das alles noch genauer erklärt sogar mit Bild ;)
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
05.10.2003, 18:24
...neu hier

Beiträge: 7
#11 Das ist ja soweit nicht wirklich neu, ich habe praktisch das gleiche Problem wie er, aber was hilft mir die Erkenntnis mit aktiv/passiv? Der angegebene Thread ist ja nur eine Darstellung der Abläufe. Aber was bedeutet das für meine Router-Settings?

Ich meine, ich stelle auf meinem FTP-Client passiv ein, und bekomme immer noch keine Datenverbindung zur anderen Seite. Wie kann ich denn den (High-)Port bestimmen, den mein FTP-Client für die Verbindung wählt?

Wenn die Erkenntnis aktiv/passiv alles wäre, müßte man das Problem doch dadurch lösen können, daß man passiv wählt, richtig?
Seitenanfang Seitenende
05.10.2003, 18:25
Member
Avatar Xeper

Beiträge: 5289
#12 @marcusb

Ja sofern die gegenseite dies Unterstüzt. Der Server muss passive ftp unterstüzen!
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
05.10.2003, 18:54
...neu hier

Beiträge: 7
#13 Das ist doch mal ein Wort!

Damit ist mir nun klar, warum einige funzen und andere nicht.

Danke
Dieser Beitrag wurde am 05.10.2003 um 18:56 Uhr von marcusb editiert.
Seitenanfang Seitenende
13.12.2003, 00:13
...neu hier

Beiträge: 2
#14 Hallo,

habe ein ähnliches Problem, nur habe ich keinen Hardware Router sondern hinter einem Fli4L Software Router, ein LAN mit 2 Stck. FTP Servern, der eine mit suse 7.0 & proftp 1.2.2, der andere mit suse 8.1 & proftp 1.2.9. Das witzige ist, von aussen komme ich immer, ob mit dsl, analog oder isdn auf den 1. FTP. Auf den 2. FTP komme ich nur per analog & isdn.

Im Fli4L Router liegt der 1.FTP auf aussen: 21 & innen: 21. Der 2. FTP liegt auf aussen: 2121 & innen: 2121.

Mit aktiv oder passiv hat das nicht viel zu tun, glaube ich. Habe an meinem FTP Cleint schon soviele Hebel verändert und gemacht, gelesen und getan >>> keine Chance nix mit DSL und dem 2. FTP, aber mit analog oder isdn ja.

MAche jetzt nochmal nen remote router reboot, mal schauen.

Horschdi
Seitenanfang Seitenende
13.12.2003, 01:34
Member
Avatar Xeper

Beiträge: 5289
#15 @horschdi

ganz gleich welches OS du nutzt das Prinzip ist und bleibt das selbe - ein reboot wird dir da nicht helfen sowas brauchst du bei Linux nicht zu tun und ich denke mal fli4l wird einen Linux kernel nutzen. Du willst jetz sagen wenn ich (ich hab ADSL) auf deinen 2. FTP Server connecten will geht das nicht - ich brauch ANALOG oder ISDN?
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: