kein Zugriff auf Musikserver

#0
20.12.2012, 19:05
Member

Themenstarter

Beiträge: 122
#16 Aktive Internetverbindungen (Nur Server)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:51948 *:* LISTEN 887/rpc.statd
tcp 0 0 *:sunrpc *:* LISTEN 875/portmap
tcp 0 0 localhost:ipp *:* LISTEN 1557/cupsd
tcp 0 0 localhost:smtp *:* LISTEN 1440/exim4
udp 0 0 *:bootpc *:* 1455/dhclient
udp 0 0 *:41165 *:* 1477/avahi-daemon:
udp 0 0 *:mdns *:* 1477/avahi-daemon:
udp 0 0 *:sunrpc *:* 875/portmap
udp 0 0 *:ipp *:* 1557/cupsd
udp 0 0 *:639 *:* 887/rpc.statd
udp 0 0 *:52240 *:* 887/rpc.statd

Ich hoffe so ist es übersichtlicher
Gruss
Seitenanfang Seitenende
20.12.2012, 19:15
Member

Themenstarter

Beiträge: 122
#17 SocksoModule: Using HSQL Database
Das hier könnte vielleicht auch noch interessant sein


JDBCDatabase: Column already exists in statement [ alter table users add is_active char(1) default '1' not null ]
Main: Initializing Resources (null)
Main: Loading Properties
Main: Starting Scheduler
Main: Starting Collection Manager
IpFinder: Fetching IP from http://sockso.pu-gh.com/nat/ip/
Main: Starting Web Server
HttpServer: Listening on 4444
CommunityUpdater: java.io.IOException: Server returned HTTP response code: 400 for URL: http://sockso.pu-gh.com/community/ping
TrayIcon: Creating JDIC Tray Icon
CommunityUpdater: java.io.IOException: Server returned HTTP response code: 400 for URL: http://sockso.pu-gh.com/community/ping
Seitenanfang Seitenende
20.12.2012, 20:58
Member
Avatar Gool

Beiträge: 4730
#18 Also, da lauscht nichts auf Port 4444. Sockso ist gar nicht in der Liste der Programme drin.

Die Ausgabe vom SocksoModule ist leider nicht sehr aussagekräftig. Er zeigt nur nen Fehler an, dass er die Ping-URL nicht erreichen kann. Fehler 400 weist darauf hin, dass ungültige Daten gesendet wurde.

Ich würde nochmal die Syslogs anschauen und gucken, ob dort was zu finden ist.
__________
Dies ist eine Signatur! Persönlicher Service: Du kommst aus Berlin? Dann melde Dich per PN bei mir, evtl. können wir einen Termin vereinbaren.
Der Grabsteinschubser
Seitenanfang Seitenende
20.12.2012, 22:18
Member
Avatar Xeper

Beiträge: 5285
#19

Zitat

Conzemius postete
Hier noch eine andere Liste...im Anhang.
Wie Gool schon sachte, screenshots sind hier falsch.
Halte dich bitte genau an die manpage von netstat - alles ist immer case-sensitive.

Edit:
Nanu, hatte gar nicht gemerkt das wir schon auf der 2. Seite sind. ;)
Dann schlage ich vor du machst mal folgenden Test:

Code

telnet localhost 4444
- kommt etwas?

Wie Gool sagte, tcp/4444 ist nicht geöffnet, somit kannst du auch keine Verbindung aufbauen.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Dieser Beitrag wurde am 20.12.2012 um 23:55 Uhr von Xeper editiert.
Seitenanfang Seitenende
21.12.2012, 11:13
Member
Avatar Gool

Beiträge: 4730
#20 Ok, interessanterweise funktioniert Sockso in meiner virtuellen Testmaschine und ich sehe es nicht bei netstat. Welche Version von Sockso verwendest Du? Welche Version von Debain verwendest Du? Sind alle Pakete auf dem aktuellen Stand? In der Manual steht auch, dass Sockso nicht mit GCJ funktioniert - hast Du die (aktuelle) Oracle Java Runtime installiert?

Meine Konfiguration: Debian 6.0.6 mit Java 6 (apt-get install default-jre) und Sockso 1.5.3.

Nachtrag: doch, hab es gefunden: netstat -ap
...
tcp6 0 0 [::]:4444 [::]:* LISTEN 3191/java
...
__________
Dies ist eine Signatur! Persönlicher Service: Du kommst aus Berlin? Dann melde Dich per PN bei mir, evtl. können wir einen Termin vereinbaren.
Der Grabsteinschubser
Dieser Beitrag wurde am 21.12.2012 um 11:19 Uhr von Gool editiert.
Seitenanfang Seitenende
21.12.2012, 11:28
Member
Avatar Xeper

Beiträge: 5285
#21

Zitat

Nachtrag: doch, hab es gefunden: netstat -ap
...
tcp6 0 0 [::]:4444 [::]:* LISTEN 3191/java
...
Benutzt also einen v6 socket, ich wette mal das wird von der Java API gekapselt -
aber wenn es so ist dann heißt das im Umkehrschluß das du dich nicht über native v4 verbinden kannst.

Edit:
@Gool
Du könntest mal testen ob du dich über 127.0.0.1 via telnet verbinden kannst -
dann schauen kannst wie das in netstat gelistet wird, eventuell wird das ja automatisch
durch die v6/v4 conv gemapped - dann müßte da sowas wie ::ffff:127.0.0.1 stehen.
Aber soweit ich weiß, ist das kernel-config abhängig.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Dieser Beitrag wurde am 21.12.2012 um 11:49 Uhr von Xeper editiert.
Seitenanfang Seitenende
21.12.2012, 12:52
Member
Avatar Gool

Beiträge: 4730
#22 Hehe:

tcp 0 0 localhost:4444 localhost:52818 VERBUNDEN -
tcp6 0 0 localhost:4444 localhost:52818 VERBUNDEN 3191/java
__________
Dies ist eine Signatur! Persönlicher Service: Du kommst aus Berlin? Dann melde Dich per PN bei mir, evtl. können wir einen Termin vereinbaren.
Der Grabsteinschubser
Seitenanfang Seitenende
21.12.2012, 12:58
Member
Avatar Xeper

Beiträge: 5285
#23

Zitat

Gool postete
Hehe:

tcp 0 0 localhost:4444 localhost:52818 VERBUNDEN -
tcp6 0 0 localhost:4444 localhost:52818 VERBUNDEN 3191/java
Ja mach mal mit -n dann müßte der die Adresse anzeigen.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
21.12.2012, 13:00
Member

Themenstarter

Beiträge: 122
#24 Hallo,
ich habe telnet eingegeben: Antwort fehlgeschlagen trying 127.0.0.1... nach Eingabe von 127.0.0.1 kam als Antwort
unable to connect to remote host: connection refused
Die Version von sockso ist die 1.5.3. Die Debian ist eine gebrannte Iso-Datei, Version Nummer 1:2.8.2 architec:i386
Gruss
Seitenanfang Seitenende
21.12.2012, 13:01
Member
Avatar Xeper

Beiträge: 5285
#25

Zitat

Conzemius postete
Hallo,
ich habe telnet eingegeben: Antwort fehlgeschlagen trying 127.0.0.1... nach Eingabe von 127.0.0.1 kam als Antwort
unable to connect to remote host: connection refused
Die Version von sockso ist die 1.5.3. Die Debian ist eine gebrannte Iso-Datei, Version Nummer 1:2.8.2 architec:i386
Gruss
Probier nochmal:
telnet ::1 4444
sowie die beiden auch jeweils:
telnet ::127.0.0.1 4444
telnet ::ffff:127.0.0.1 4444
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
21.12.2012, 16:29
Member

Themenstarter

Beiträge: 122
#26

Zitat

Xeper postete

Zitat

Conzemius postete
Hallo,
ich habe telnet eingegeben: Antwort fehlgeschlagen trying 127.0.0.1... nach Eingabe von 127.0.0.1 kam als Antwort
unable to connect to remote host: connection refused
Die Version von sockso ist die 1.5.3. Die Debian ist eine gebrannte Iso-Datei, Version Nummer 1:2.8.2 architec:i386
Gruss
Probier nochmal:
telnet ::1 4444
sowie die beiden auch jeweils:
telnet ::127.0.0.1 4444
telnet ::ffff:127.0.0.1 4444
Hallo
diese 3 Kommandos in der shell findet er nicht
bash antwortet: Kommando nicht gefunden
Gruss
Seitenanfang Seitenende
21.12.2012, 16:34
Member
Avatar Xeper

Beiträge: 5285
#27 Dann ist deine Shell kaputt, nimm mal eine andere - du hast ja telnet vorher auch ausgeführt,
dass ist jetzt nichts anders nur andere Argumente:

Zitat

therion@aquina ~ > telnet ::127.0.0.1 4444 <15:17
Trying ::127.0.0.1...
telnet: connect to address ::127.0.0.1: Invalid argument
telnet: Unable to connect to remote host

__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
21.12.2012, 16:49
Member

Themenstarter

Beiträge: 122
#28 Habe noch einmal telnet ::1 4444 eingegeben und erhielt
als Antwort diesmal: Connected to ::1
Escape character is '^].
Seitenanfang Seitenende
21.12.2012, 16:59
Member

Themenstarter

Beiträge: 122
#29 Das dritte Kommando telnet::ffff:127.0.0.1 4444 gibt ebenfalls als Antwort
Connected to: ffff:127.0.0.1 Escape character is '^]

Der mittlere telnet::127.0.0.1 4444 sagt kein Kommando gefunden.

Gruss
Seitenanfang Seitenende
21.12.2012, 17:10
Member
Avatar Xeper

Beiträge: 5285
#30

Zitat

Der mittlere telnet::127.0.0.1 4444 sagt kein Kommando gefunden.
Ja du machst zuviele Typos du musst mal exakt richtig eingeben,
aber wohl noch nicht so die Tastatur gewöhnt. ;)

Aber macht nichts, im Grunde würde ich sagen das läuft bei dir schon,
die Frage ist jetzt ob es auch auf deine LAN Adresse hört -
welche wäre das denn für diese Maschine?
Dann könntest du das nämlich damit nochmal probieren,
wenn das auch funktioniert dann liegt es an deinem Router.
Bzw. an deinen Port-Forwarding Einstellungen.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: