Batchdatei immer als Administartor ausführen?

#0
21.07.2009, 16:42
Member

Beiträge: 183
#1 Hallo,
wie kann ich eine Bachtdatei immer als Administartor ausführen? Ich nutze Windows Vista und Windows 7 (geht so bei keinem von beiden). Rechte Maustaste->Eigenschaften->Kompatibilität---->das geht nicht, das Feld ist grau hinterlegt...
Ich hab nämlich eine kleine Batch geschrieben die mithilfe des "at"-Befehls, den PC herunterfährt, aber eben nur wenn es als Admin gestartet wird.
Seitenanfang Seitenende
21.07.2009, 23:09
Moderator
Avatar hevtig

Beiträge: 2307
#2 ähm, sorry, aber was ist ein at- Befehl?
Ich versteh das anliegen auch nicht so recht.
Musst du das als Admin ausführen, damit es geht?
Oder willst du, dass es nur als Admin geht?

Benutze doch einfach den shutdown- Befehl, um den Rechner herunterzufahren. Ab User aufwärts sollte das keine Probleme bringen.
Verknüpfung anlegen mit "shutdown.exe -s -t 3" und gut ist.

Willst du es mit einer .bat machen, dann gibt es auch im Kontextmenü "als Admin ausführen".

Willst du es erzwingen, dass man sich als Admin anmelden muss nutzt du den Befehl 'runas' in deiner .bat.
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
22.07.2009, 00:41
Member

Themenstarter

Beiträge: 183
#3 Ich muss es als Admin ausführen.

Ein at-Befehl ist eine Aufgabenplanung, er gibt die Zeit an zu der etwas getan werden soll.
Bsp:

at [zeit in HH:MM] [Befehl bzw auszuführende Datei]

Damit das nun aber wirklich in die Aufgabenplanung aufgenommen wird muss die Datei als Administrator ausgeführt werden, ansonsten kommt die Meldung "Zugriff verweigert", jedemals rechte Maustaste und "Als Administrator" ausführen ist zwar nich umständlich, aber doch irgendwie nervig. Deswegen würde ich das gerne IMMER als Administrator ausführen, aber die Option kann ich nicht anwählen.

Hmm.... runas... Da muss ich dann ja immer noch ein PW eingeben (was er irgendwie nicht annimt) und ich möchte da eig nur Draufklicken und es wird als Admin gestartet... Mit ALLEN anderen Programmen kann ich auswählen, dass es immer als Admin gestartet werden soll nur da nicht!

Ich hoffe du hast mich jetzt verstanden ;-)
Dieser Beitrag wurde am 22.07.2009 um 01:00 Uhr von Legonzo editiert.
Seitenanfang Seitenende
22.07.2009, 08:56
Member
Avatar TurnRstereO

Beiträge: 1539
#4 Ich wußte es!

Habe nur die Überschrift gelesen und dachte mir so im stillen Kämmerlein, daß das nur ein Thread von Legonzo sein kann.
Und siehe da, es ist so. Ich sollte als Jahrmarktwahrsager gehen.

Die Thematik ist nicht neu, hier mal ein paar links dazu, da haste genug Stoff zum Testen:
http://www.axel-hahn.de/axel/page_compi/bat_runas.htm
http://www.heise.de/software/download/machmichadmin/31780
http://www.benutzer.de/Adminrelevante_Dateien_und_Dienste_als_Benutzer_starten_(RUNAS-Problematik).html

Und schaff dir endlich eine vernünftige Suchmaschine an.

TS
Seitenanfang Seitenende
22.07.2009, 10:19
Member

Themenstarter

Beiträge: 183
#5 Wenn das so einfach wäre, dann hätte ich das schon geschafft, aber leider funktionieren diese Sachen nich unter Vista...
Seitenanfang Seitenende
07.06.2012, 10:52
...neu hier

Beiträge: 1
#6 hmm mach die cmd console über start/Programme/zubehör/Console ein damit haste die adminrechte hat bei mir auch funktioniert
mfg
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: