VPN Verbindung via Windows XP aber wie gehts weiter ?!

#0
23.03.2008, 15:32
Member

Beiträge: 58
#1 Hi Leute ,

ich hab heute mal eine VPN Verbindung mit dem Windows internen Tool eingerichtet und kann mich auch verbindne ...

Jetzt ist es aber so , wenn ich mich mit dem VPN verbunden habe kann ich leider keine Internetseite mehr öffnen ? Und das ist eigentlich das was ich damit machen möchte ?

kann mir einer sagen wie ich da weiter verfahren muss / soll ?
Seitenanfang Seitenende
23.03.2008, 19:10
Member

Beiträge: 546
#2 Du setzt bspw. auf dem VPN-Gateway bzw. dem VPN-Server einen lokalen HTTP-Proxy auf und richtest ihn ein.
Auf dem VPN-Client konfigurierst du deinen bevorzugten Browser so, dass er den Proxy des VPN-Server benutzen
soll. Dazu trägst du zwingend(!) die VPN-IP (LAN) ein, die der entfernte VPN-Server besitzt.

Außerdem muß in den Eigenschaften des VPN Zugangs des Clients unter "Eigenschaften -> Netzwerk ->
Internetprotokoll -> Erweitert" der Haken bei "Standardgateway für das Remotenetzwerk verwenden" gesetzt sein.
Letzteres ist bei dir aber wahrscheinlich der Fall, ansonsten könntest du nämlich derzeit problemlos im WWW surfen
(die Verbindung ins WWW würde jedoch nicht über den VPN-Server etabliert werden).

Gruß,

Sepia
Seitenanfang Seitenende
24.03.2008, 14:52
Member

Themenstarter

Beiträge: 58
#3 hi danke für deine Info , aber hab da noch paar fragen :

1.) wie richte ich am besten so einen HTTP - Proxy ein ? und anders geht das surfen sonst nicht oder ?
2.) die VPN-LAN ist das die LAN des Rechners selber oder der VPN - Verbindung , die sind ja auch wieder unterschiedlich ?
3.) jap der haken ist bei mir gesetzt , wenn ich den entferne kann ich normal surfen , aber wie du schon sagst ja dann nicht über VPN .

Da wäre dann noch eine Frage, wie seh ich überhaupt ob ich über den VPN surfe oder Emails abhole ??
Seitenanfang Seitenende
24.03.2008, 15:09
Member

Beiträge: 1516
#4 Imho brauchst du kein Proxy. Beim Server kannst du einstellen das er die Anfragen weiterleitet. Lässt sich auch irgendwo bei Eigenschaften der Verbindung einstellen.
Kanns leider gerade nicht testen, vielleicht erinnere ich mich auch nur falsch.
__________
°<- Vorsicht Trollköder und Trollfalle -> {_}
Seitenanfang Seitenende
24.03.2008, 15:31
Member

Themenstarter

Beiträge: 58
#5 ich hab grad nochmal geschaut aber leider nix gefunden


was ich machen möchte ist über den vpn surfen und emails abholen können


gruss
Seitenanfang Seitenende
24.03.2008, 17:24
Member

Beiträge: 647
#6 Mir fehlen da ehrlich gesagt die Angaben, um da helfen zu können... Mich würde erst mal interessieren wie und womit du dich auf den VPN-Server einwählst, und vor allem wie dieser konfiguriert ist und in was für einer Netzwerktopologie der steht.
__________
Es ist nicht wenig Zeit, die wir haben, sondern viel Zeit, die wir nicht nutzen...
Seitenanfang Seitenende
24.03.2008, 17:45
Member

Beiträge: 546
#7

Zitat

Imho brauchst du kein Proxy. Beim Server kannst du einstellen das er die Anfragen weiterleitet.
Bei einem Server-OS hast du recht. Ich gehe aber von 2 x XP-Pro aus. IIRC besteht keine Möglichkeit an
den VPN-Eigenschaften des XP VPN-Servers diesbezüglich zu schrauben. Anfragen vom Client ins WWW über
den XP VPN-Server sollten scheitern. Wenn ich mich jedoch irre, be-
richtige mich bitte!

Golf16v schrub:

Zitat

1.) wie richte ich am besten so einen HTTP - Proxy ein ?
Naja, du installierst und konfigurierst ihn. Hört sich jetzt dämlich an, aber bei der Vielzahl an kostenloser Proxy-
Software ist eigentlich immer ein gutes Readme dabei.

Zitat

und anders geht das surfen sonst nicht oder ?

Zitat

was ich machen möchte ist über den vpn surfen und emails abholen können
TOR. Wenn ich davon ausgehe, dass du beim anderen Thread (http://board.protecus.de/t33017.htm)
lediglich anonym surfen und mailen möchtest, wäre das die einfachste Lösung. Da GMX Webmail selbst in der
Free-Variante für den Login HTTPS benutzt sehe ich da keine sicherheitsrelevanten Probleme.
Es sei denn, der Inhalt der Mail ist dir so wichtig, dass nur eine Ende-zu-Ende Verschlüsselung in Frage kommt
und du dem Exit-Node nicht traust.

Reines anonymes surfen ist sowieso kein Problem, dafür ist TOR prädestiniert.

Zitat

2.) die VPN-LAN ist das die LAN des Rechners selber oder der VPN - Verbindung , die sind ja auch wieder unterschiedlich ?
Wie meinen? Geht es um die IP die im Browser eingetragen werden muß?

Zitat

Da wäre dann noch eine Frage, wie seh ich überhaupt ob ich über den VPN surfe oder Emails abhole ??
1.) "tracert blah.test" beim Client eingegeben wird dir die Routen und das Gateway mitteilen.

2.) Irgendeine Seite mit dem Client ansurfen, die dir deine aktuelle IP auflistet. Diese vergleichst du mit deiner
dem Client zugewiesenen WAN-IP. Beide sollten differieren.

3.) 2 x lediglich DSL Verbindung? Dann wirst du das an den Downloadraten beim Client merken.


Gruß,

Sepia
Seitenanfang Seitenende
24.03.2008, 18:34
Member

Beiträge: 1516
#8 Hab es getestet, es funktioniert mit Xp Prof. Habe das Vpn lediglich über den Assistenten eingerichtet. Da gibt es also eine Einstellung.
Vielleicht "Zugriff aus das Lokale Netzwerk" und den Rest erledigt der Router?
Kann leider nicht testen welche Einstellung, da ich den Server auf keinen Fall lahmlegen darf.
__________
°<- Vorsicht Trollköder und Trollfalle -> {_}
Seitenanfang Seitenende
24.03.2008, 19:15
Member

Beiträge: 546
#9

Zitat

Vielleicht "Zugriff aus das Lokale Netzwerk" und den Rest erledigt der Router?
Wenn du da den Haken entfernst, dürftest du dich mit dem Client gar nicht mehr am Server anmelden können.
So gesehen muß diese Option also aktiviert sein, hat bei mir jedoch ansonsten keine Wirkung auf die Nutzung des
WANs von einem Client aus.

Nochmals, damit ich das richtig verstehe: Du hast also 2 XP-Pro Systeme von denen einer als VPN-Server agiert.
Dein Client kann ohne sonstige Software über den VPN-Server ins Internet? Um Missverständnisse
auszuschließen: Wenn du am Client die Option "Standardgateway für das Remotenetzwerk verwenden" deaktiviert
hast, funktioniert zwar vom Client aus der Internetzugriff, jedoch wird der Traffic nicht über den VPN-
Server geleitet.

Bist du dir sicher, dass der Internetverkehr vom Client über den VPN-Server getunnelt wird? ;)

Falls ja: Wenn du irgendwann Zeit hast, teile mir gerne mal die Konfiguration mit. Ich hab´s bis dato nur immer über
einen Proxy hinbekommen.


Gruß,

Sepia
Seitenanfang Seitenende
24.03.2008, 21:13
Member

Beiträge: 1516
#10 Ja 2 Xp Pro Systeme. Hab die Ip Adressen überprüft der Verkehr wurde getunnelt.

Es muss sich um die standard Konfiguration handeln. Hab mich da nur einmal durchgeklickt und das wars.
__________
°<- Vorsicht Trollköder und Trollfalle -> {_}
Seitenanfang Seitenende
24.03.2008, 22:08
Member

Beiträge: 546
#11

Zitat

Es muss sich um die standard Konfiguration handeln.
Merkwürzig, funktioniert bei mir definitiv nicht. Anyway, wenn´s denn bei dir klappt, werde ich den Ansatz mal
verfolgen.

Bei mir sieht es so aus:

Szenario 1:

1 x XP Pro VPN-Server
1 x XP Pro VPN-Client (oder wahlweise auch W2K)

Alle Hosts stehen in einem LAN, also auch der Server. Wenn der Client eine VPN-Verbindung etabliert hat,
komme ich entweder mit besagtem Client nicht ins WAN ("Standardgateway für das Remotenetzwerk verwenden" aktiviert)
oder eben ich habe Zugang zum Internet sofern ich o.g. Option deaktiviere.

Ein tracert zu heise.de vom Client aus, bei aktivierter Option, läuft ins Leere (generell kein WAN-Zugang).
Das tracert endet in diesem Fall beim VPN-Server.

Bei deaktivierter Option wird als erster Hop sofort mein Router und nicht etwa der VPN Server aufgelistet. Normalerweise müsste ein
ein tracert jedoch so aussehen:

> 1. Hop: 192.168.3.200 (<- VPN-Server)

erst dann...

> 2. Hop: 192.168.1.254 (<- DSL-Router)
(oder der Router ist meinetwegen der 3. Hop, wenn der Server noch ins 1´er Netz routet (Nic) und erst dann zum Router)

WAN funktioniert dann also auf dem Client, aber wie erwähnt wird bei mir der Verkehr nicht getunnelt.

Szenario 2:

1 XP Pro VPN Server
1 XP Pro VPN Client

Der Server ist im WAN, steht also nicht lokal im LAN.
Der Rest ist fast identisch. Kein Zugang zum Internet nach erfolgter VPN-Verbindung vom Client aus, wenn
die besagte Option aktivert ist.
Deaktiviere ich die Option beim Client, komme ich zwar ins Netz, nutze aber definitiv dafür meine eigene WAN-IP.

Gruß,

Sepia

PS: Du bist dir wirklich ganz, ganz sicher? ;)
Seitenanfang Seitenende
24.03.2008, 23:58
Moderator
Avatar hevtig

Beiträge: 2307
#12 Würde es nicht einfach reichen für die VPN- Verbindung die Internetverbindungsfreigabe einzurichten? habe grad kein xp parat...
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
25.03.2008, 00:39
Member

Beiträge: 546
#13

Zitat

Würde es nicht einfach reichen für die VPN- Verbindung die Internetverbindungsfreigabe einzurichten?
K.A. ;) Wenn ja, wie konfigurierst du das? ICS setzt doch soweit ich weiss eine WAN-Verbindung durch analoges Modem,
ISDN oder DSL-Modem (nicht Router!) voraus. Also eine Direktverbindung zum WAN, von mir aus per lokalem
PPPoE.

Wenn man aber eine Internetverbindung mittels Router und LAN-Netzwerkkarte herstellt, ist ICS doch
gar nicht verfügbar(?). Wenn doch, wo? ;) Ich finde jedenfalls nichts bei den diversen Einstellungen.

So aus dem Kopf glaube ich deshalb, ICS läßt sich nicht bei LAN<->Router Kombinationen aktivieren.

Die VPN-Software auf dem VPN-Server bietet auch nicht an, diese Verbindung per ICS weiterzuleiten bzw.
ICS zu nutzen.

Auch hier gilt: Wenn ich mich irre, bitte melden!

Wie das ganze tatsächlich mit einer Direktverbindung, ICS & VPN aussieht, käme auf einen Versuch an.

Zitat

habe grad kein xp parat...
Macht nichts, teste es einfach mal mit deinen Vista Installationen. Von mir aus auch gerne mit einer virtuellen
Maschine. ;)


Gruß,

Sepia

Edit:

Korrektur, ICS ist sehr wohl verfügbar, zum einen für die LAN-Verbindung, zum anderen für den VPN-Zugang
am Client.

ICS an der LAN-Verbindung: Kann ich nicht aktivieren bzw. läßt sich nicht aktivieren, da eine private Netzwerk-
verbindung ausgewählt werden muss, die ich mangels Direktverbindung gar nicht habe.

ICS am VPN-Client beim VPN-Zugang: Kann ich aktivieren, brachte aber erwartungsgemäß nichts.

ICS ist am VPN-Server hingegen ("Eingehende Verbindungen") nicht vorhanden.
Dieser Beitrag wurde am 25.03.2008 um 02:17 Uhr von Sepia editiert.
Seitenanfang Seitenende
25.03.2008, 09:06
Member

Themenstarter

Beiträge: 58
#14 Hi Leute habe hier gerade gespannt alles durchgelesen was ihr noch geschrieben hattet , aber so wie ich sehe seit ihr leider auch noch auf keinen nenner gekommen.

Hier ist die Anleitung nach der Ich es eingerichtet habe : http://www.wintotal.de/Artikel/vpnxp/vpnxp.php

aber wie gesagt , verbinden geht , alles kein Problem , wenn ich mich von Extern verbinde kann ich dann auch mit ner LanIP die Remoteverbindung starten z.b. ,das funktioniert auch super nur ins Web per z.b. Firefox geht nicht , wie ihr aber auch schon festgestellt habt...

@sepia du hast den anderen thread angesprochen , genau deswegen wollte ich den VPN nutzen , das auch Internetseiten wie hier z.b. nicht mitgesnifft werden können und ich somit keine bedenken haben muss . Das mit dem SSL bei gmx hab ich schon eingestellt und sieht auch so aus als würde es funktionieren ...
Seitenanfang Seitenende
25.03.2008, 10:06
Member

Beiträge: 214
#15 Oha, der Geheimagent is wieder am Start!

Verbinde Dich doch per VPN auf Deinen Rechner und geh dann innerhalb des Tunnels per RDP auf Deinen Heimrechner und surfe direkt über diesen...?
__________
the power to serve
Seitenanfang Seitenende