Vpn Tunnel von 2 Umts Laptops

#0
21.12.2007, 12:10
...neu hier

Beiträge: 7
#1 Hi!

Ich habe 2 identische Laptops, mit 2 Vodafon UMTS-Karten. Über die Software MWconn stellen diese die Internetverbindung her.
Nun will ich von dem einen Laptop auf den anderen kommen. Dazu haben wir einen ROOT-Server mit OpenVPN. Jeder Laptop kann auch den Tunnel aufbauen. Jeder Laptop kann auch den Server pingen und der Server kann auch beide Laptops pingen.
Server | 10.0.0.1 | kann beide pingen
Laptop1 | 10.0.0.2 | kann nur Server pingen, nicht Laptop2
Laptop2 | 10.0.0.3 | kann nur Server pingen, nicht Laptop1

Stellt ein Laptop aber die Internetverbindung nicht über UMTS, sondern über DSL her, kann er auch den anderen Laptop pingen und umgekehrt. Also wenn Laptop1 über DSL und Laptop2 über UMTS ins Internet gehen funktioniert alles und ich komme von Laptop1 zu Laptop2 und umgekehrt...

Wo könnte das Problem sein?
Seitenanfang Seitenende
22.12.2007, 14:40
Moderator
Avatar hevtig

Beiträge: 2308
#2 So wie sich das liest scheint es evtl. ein Latenzproblem zu sein.
Da du ja die Konfig nicht änderst und es geht, sobald 1 Client per DSL verbunden ist kann es ansich nur am UMTS und der daraus resultierenden höheren Latenz liegen.
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
23.12.2007, 09:53
...neu hier

Themenstarter

Beiträge: 7
#3 hm, kann ich das irgendwie überprüfen. Oder kann man irgendwo einstellen wie lange es dauern darf, bis die Antwort kommt?
Seitenanfang Seitenende
23.12.2007, 11:55
Moderator
Avatar hevtig

Beiträge: 2308
#4 Hmm gute Frage,

evtl. hilft es das TTL vom PING zu erhöhen. (um das erstmal zu testen...)
ping /? sagt dazu

Code

ping -i <wert> <ip>
Vielleicht hilft das weiter...
Bei mir (im normalen Netz) hat er komischerweise keine größere TTL angezeigt, aber wenn die Hilfe das so sagt... ;)
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
23.12.2007, 19:29
Member

Beiträge: 343
#5 Hallo,
du musst die Serverconfig so einstellen das sie auf die andern Netzwerkteilnehmer zugreifen können (wie im normalen Netzwerk)
probier mal diesen Syntax in der Config: client-to-client

Zitat

--client-to-client die Klienten “sehen“ dann nicht nur den OVPN-Server, sondern auch andere Klienten. Die Klienten können sich miteinander kommunizieren.
Quelle
http://www.vpnforum.de/wiki/index.php/OpenVPN-Syntax
__________
Es ist richtig, wenn Politiker behaupten: Der Mensch ist Mittelpunkt.
Falsch ist nur die Schreibweise gemeint ist: Der Mensch ist Mittel. Punkt.
Seitenanfang Seitenende
23.12.2007, 20:27
Moderator
Avatar hevtig

Beiträge: 2308
#6 Er schrieb doch aber, daß es läuft, sobald ein Client sich über DSL einwählt(?)
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
23.12.2007, 21:34
Member

Beiträge: 343
#7 ups überlesen,
könnte man aber trozdem mal probieren
__________
Es ist richtig, wenn Politiker behaupten: Der Mensch ist Mittelpunkt.
Falsch ist nur die Schreibweise gemeint ist: Der Mensch ist Mittel. Punkt.
Seitenanfang Seitenende
24.12.2007, 10:32
...neu hier

Themenstarter

Beiträge: 7
#8 Ja, die Option ist eingestellt...

ich komme halt erst am Donnerstag/Freitag wieder zu den Laptops, dann teste ich das mal mit der Latenz...


Gibt es ein Programm die Latenz künstlich zu erhöhen? Dann könnte ich das auch über DSL testen, ob es wirklich daran liegt...
Seitenanfang Seitenende
10.01.2008, 15:34
...neu hier

Themenstarter

Beiträge: 7
#9 Hallo,

hatte viel um die Ohren, aber nun gehts es weiter:

Client1:

Zitat

dev tun
remote SERVER_IP
tls-client
ca certs/vpn-ca.pem
cert certs/client1.crt
key certs/client1.key
port 1194
pull
cipher AES-256-CBC
comp-lzo
verb 3
Client2:

Zitat

dev tun
remote SERVER_IP
tls-client
ca certs/vpn-ca.pem
cert certs/client1.crt
key certs/client1.key
port 1194
pull
cipher AES-256-CBC
comp-lzo
verb 3
Server:

Zitat

dev tun
proto udp
port 1194
server 10.8.0.0 255.255.255.0
mode server
ifconfig-pool-persist /etc/openvpn/ipp.txt
tls-server
dh /etc/openvpn/certs/dh2048.pem
ca /etc/openvpn/certs/ca.crt
cert /etc/openvpn/certs/server.crt
key /etc/openvpn/certs/server.key
push „route 10.8.0.0 255.255.255.0“
cipher AES-256-CBC
status /etc/openvpn/openvpn-status.log
comp-lzo
verb 3
Das mit den Pingen funktioniert jetzt auch.
Client1 - 10.8.0.6(IP) 10.8.0.5(DHCP)
Client2 - 10.8.0.10(IP) 10.8.0.9(DHCP)

Client1 <-> Client2 funktioniert!

An Client2 ist eine WLAN Kamera angeschlossen. 10.9.0.1(WLAN IP von Client2), 10.9.0.99(IP der WLAN-Kamera)

Was muss ich jetzt noch machen, damit ich von Client1 auf 10.9.0.99 komme?

Client1: "route add 10.9.0.0 mask 255.255.255.0 10.8.0.10" hat nicht funktioniert...
Seitenanfang Seitenende
10.01.2008, 17:52
Moderator
Avatar hevtig

Beiträge: 2308
#10 Ohne VPN funktioniert das Routing auf das 10.0er Netz?
Versuch mal "route add 10.9.0.0 mask 255.255.255.255 10.8.0.10"
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
15.01.2008, 10:27
...neu hier

Themenstarter

Beiträge: 7
#11 Hallo,

also "route add 10.9.0.0 mask 255.255.255.255 10.8.0.10" bringt den gleichen Fehler wie "... mask 255.255.255.0 ..."

Hier der Fehler:
Hinzufügen der Route fehlgeschlagen: Entweder ist der Schnittstellenindex ungültig oder das Gateway befindet sich nicht im gleichen Netzwerk wie die Schnittstelle. Überprüfen Sie die IP-Adresstabelle für diesen Rechner.

Wie ich von dem einen Laptop in das 10.9.0.0er Netz von dem anderen Laptop?

EDIT:

Hi,

also der route-Befehl hat nicht funktioniert, weil die Laptops folgende Subnetzmaske hatten: 255.255.255.252

Das ist nun korrigiert, die Route steht, aber trotzdem kann ich nicht pingen:

Laptop1:
VPN
10.8.0.6(IP-Adresse)
255.255.255.0(Subnetzmaske)

Laptop2:
VPN
10.8.0.10(IP-Adresse)
255.255.255.0(Subnetzmaske)
WLAN
10.9.0.1(IP-Adresse)
255.255.255.0(Subnetzmaske)

WLAN-Cam:
10.9.0.99(IP-Adresse)
255.255.255.0(Subnetzmaske)
10.8.0.10(Gateway)

Auf Laptop1: route add 10.9.0.0 mask 255.255.255.0 10.8.0.10 -> Erfolg

Auf Laptop1: ping 10.9.0.1 -> kein Erfolg
Auf Laptop1: ping 10.9.0.99 -> kein Erfolg
Dieser Beitrag wurde am 15.01.2008 um 15:09 Uhr von Monkey editiert.
Seitenanfang Seitenende
15.01.2008, 21:47
Moderator
Avatar hevtig

Beiträge: 2308
#12 Klappt es denn ohne VPN?
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
15.01.2008, 23:44
...neu hier

Themenstarter

Beiträge: 7
#13 Das Problem ist ja, dass ich es ohne VPN nicht testen kann...

Die 2 Laptops kommen über UMTS ins Internet und haben so ja keine direkte Verbindung zueinander...

Deswegen baue ich ja überhaupt einen VPN-Tunnel auf...
Seitenanfang Seitenende
18.01.2008, 12:26
...neu hier

Themenstarter

Beiträge: 7
#14 So, habe beide Laptops mit einem Switch verbunden.

Laptop1
LAN
IP 192.168.1.1
SM 255.255.255.0

Laptop2
LAN
IP 192.168.1.2
SM 255.255.255.0
WLAN
IP 10.9.0.1
SM 255.255.255.0

Routing ist auf beiden Laptops aktiviert.
Auf Laptop1 "route add 10.9.0.0 mask 255.255.255.0 192.168.1.2" ausgeführt.

Hat alles funktioniert und ich kann von Laptop1 10.9.0.99 erreichen. So funktioniert also alles. Also müsste der Fehler im VPN zu suchen sein, oder?
Seitenanfang Seitenende
18.01.2008, 20:47
Moderator
Avatar hevtig

Beiträge: 2308
#15

Zitat

Monkey postete
Hat alles funktioniert und ich kann von Laptop1 10.9.0.99 erreichen. So funktioniert also alles. Also müsste der Fehler im VPN zu suchen sein, oder?
Tja, sieht tatsächlich so aus.
Ich bin leider nicht so bewandert mit openvpn.
Ich kann mir ansonsten noch vorstellen, daß der Sevrer vllt die Pakete an das 9er Netz verwirft. Vielleicht kann man in dessen Einstellungen auch noch konfgrurieren, daß über ihn das 9er Netz verfügbar ist.
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: