FreeS/WAN mit Suse 9.0

#0
13.01.2004, 12:44
...neu hier

Beiträge: 5
#1 Hallo,

ich hoffe, dass ihr mir helfen könnt.
Ich habe gerade Suse 9.0 Professional nach Standardinstallation plus FreeS/WAN Paket installiert.
Habe die Dateien ipsec.conf und ipsec.secrets angepasst und wollte den Tunnel testen.
Haben folgendes eingegeben:

ipsec verify

Ich bekam 2 Fehler:

Checking for KLIPS support on kernel [FAILED]
Checking that pluto is running whack:pluto is not running (
(no "/var/run/pluto.ctl")

Ich hab keine Ahnung wieso diese Fehlermeldungen kommen.
Eigentlich sollte FreeS/WAN doch laufen, wenn es schon extra der Distribution beiliegt ?!


Für jede Hilfe dankbar...
Seitenanfang Seitenende
15.01.2004, 01:08
Member
Avatar Xeper

Beiträge: 5288
#2 Viel kann ich nicht dazu sagen außer:

Satz eins sagt aus das der kernel keinen support dafür haben zu scheint.
A) kernel neu kompilieren B) nötiges modul laden (falls existent)

Satz zwei sagt aus das etwas namens 'Pluto' benötigt wird - scheint wohl ein Programm zu sein. Es muss also aktiviert werden.

Und darüber hinaus nur weil etwas der Distribution beiliegt ist es keine Garantie dafür das etwas ohne Hindernisse funktioniert.
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
15.01.2004, 09:42
...neu hier

Themenstarter

Beiträge: 5
#3 Hallo alle zusammen....

Danke Xeper, aber habe das Problem nu gelöst.

Habe es mit Suse 9.0 nicht geschafft, allerdings mit Redhat 9.0.
Man benötigt folgende Quellen:
Habe mir dazu Redhat 9.0 (3 CDs) aus dem Netz geladen http://www.redhat.com

Zusätzlich gibt es vorgefertigte RPMs von freeswan für Redhat bei ftp://ftp.xs4all.nl/pub/crypto/freeswan/binaries/RedHat-RPMs
In diesem Verzeichnis stehen weitere Verzeichnisse, die nach den entsprechenden Kernel Versionen benannt sind.
Finde vorher herraus welchen Kernel du besitzt:

uname -r

Lade dir dann aus dem dazugehörigen Verzeichnis die Pakete:
1. das Freeswan Modul für deinen Kernel z.B. freeswan-module-2.04_2.20.8-0.i386.rpm
2. das Userland Modul z.B. freeswan-userland-2.04_2.4.20_8-0.i386.rpm
3. den sigkey z.B. freeswan-sigkey.asc

Mit Hilfe der Anleitung von http://www.freeswan.org/freeswan_trees/freeswan-2.04/doc/quickstart.html
funktionierte es schliesslich.

Kurz zusammen gefasst:

Importiere die asc Datei in die RPM-Datenbank
rpm --import freeswan-rpmsign.asc

Dann kannst du überprüfen ob es geklappt hat
rpm --checksig freeswan*.rpm

und du solltest das erhalten

freeswan-module-2.04_2.4.20_20.9-0.i386.rpm: pgp md5 OK
freeswan-userland-2.04_2.4.20_20.9-0.i386.rpm: pgp md5 OK

Jetzt kannst du die freeswan rpms installieren

rpm -ivh freeswan*.rpm

Testen kannst du freeswan mit

ipsec verify

wenn alles funktioniert erhälst du
Checking your system to see if IPsec got installed and started correctly
Version check and ipsec on-path [OK]
Checking for KLIPS support in kernel [OK]
Checking for RSA private key (/etc/ipsec.secrets) [OK]
Checking that pluto is running [OK]
...


Jetzt sollte alles klappen
Viel Spaß
Seitenanfang Seitenende
15.01.2004, 13:52
Member
Avatar Xeper

Beiträge: 5288
#4 Schön das du es geschafft hast - jedenfalls gleich ein komplettes OS neu zuinstallieren oder zu wechseln ist nicht die eigentliche Lösung eines Problems. Darüber ist SuSE wie auch Redhat schrott - prinzipiell gesehn.
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: