Verbindung zwischen VLANs

#0
15.07.2008, 20:06
...neu hier

Beiträge: 3
#1 Hallo,

Wie stelle ich es an, dass ich von einem VLAN, indem z.B. nur Clients sind auf ein anderes VLAN indem Server, Router usw. sind zu zu greifen.

Hintergrund bei der Geschichte ist, dass ich zwei Organisationen getrennt auf zwei VLANs haben, die dann aber gemeinsame Resourcen wie z.B. Server und Router verwenden. Diese Geräte verfügen weder über zwei NICs / LAN Ports und können auch kein IEEE 802.1q (VLAN-Tagging).

Ich habe zwei Routing Switches zur Verfügung. Richtige Routing-Einträge kann man daran aber leider nicht vornehmen. Man kann Routing nur ein- bzw. ausschalten.

Wie schaffe ich es jetzt also, dass ich von einem Client in einem VLAN auf einen Server im anderen VLAN zugreifen kann?

Bin für jede Hilfe dankbar :-)
Seitenanfang Seitenende
15.07.2008, 21:23
Moderator
Avatar hevtig

Beiträge: 2298
#2 Hmm, was du schreibst ist ein wenig... seltsam.
aber ich verrate dir schonmal die Lösung, die mE richtig ist: du musst routen.
Da du weder geschrieben hast, um welche L3- Switches es sich handelt, noch den Grund, warum das so eingerichtet wurde, wenn du nicht genau weißt, wie das handzuhaben ist, läßt sich dir also nur schwer helfen.
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
15.07.2008, 23:11
...neu hier

Themenstarter

Beiträge: 3
#3 Ja, das mit dem routen hab ich mir auch schon gedacht. Die Switches können aber wie gesagt keine Routingeinträge. Nur an und aus.
Ich wollte das ganze (habe ich auch schon erfolglos getestet^^) über statische routen an den clients / servern selbst handeln. Habe hierzu das Zielnetz, die Maske und das Gateway (also die IP Adresse des Switches in dem VLAN, in dem der Client ist, bei dem ich die Route eintrag) angegeben. Die Rückroute hab ich natürlich auch beim Gegenüber eingetragen... Aber wie gesagt: Das ganze hat leider nicht so funktioniert wie ich mir das vorgestellt habe. Ein weiterer Router würde das Problem evtl. lösen, aber aus Budgetgründen soll die Beschaffung eines solchen vermieden werden.

Zu den Switches: Es handelt sich um HP Procurves 26er Reihe. (1x 2650, 1x 2626).
Den Grund habe ich eigentlich schon beschrieben, aber ich versuchs nochmal: Ein Gebäude mit zwei Organisationen. Die Beiden Organisationen sollen logisch getrennt werden haben aber Geräte, also Server und Router, auf die sie gemeinsam zugreifen sollen / müssen. Die Geräte können kein VLAN Tagging und haben keine zwei NICs, können also folglich nicht in beide VLANs aufgenommen werden, da sie als untagged konfiguriert sind.
Seitenanfang Seitenende
16.07.2008, 14:17
Moderator
Avatar hevtig

Beiträge: 2298
#4 nein, an den clients kann das nichts bringen, da die wenigsten ja vlan-tagging unterstützen.
Da ich mich mit den HP- Switchen nicht auskenne werde ich keine große Hilfe sein.
Ich kann nur vermuten, daß du die routing- engine aktivieren mußt und dann dort, vermutlich per konsole, ssh etc, die Routen eintragen mußt.
Du scheinst das Ganze ja nicht eingerichtet zu haben. Kann derjenige, der es ursprünglich eingerichtet hat nicht weiterhelfen?
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende
17.07.2008, 09:27
...neu hier

Themenstarter

Beiträge: 3
#5 Ich bin der jenige der die Kisten einrichten soll. Leider...
Bin noch ziemlich neu auf dem Gebiet VLAN, aber der einzige in meiner Firma, der eine Schulung von Procurve hat. Und mit VLAN kennen sich die Kollegen leider auch nicht sonderlich aus.

Wieso müssen die Clients VLAN Tagging können. Das ist doch nur dazu da, damit das Gerät, das die Technik beherrscht weiß zu welchem VLAN es die empfangenen Pakete zuordnen muss...

Habe mir das eigenltich so gedacht, dass ich an jedem Client den Eintrag mache, dass wenn er ins Netz 10.56.192.0/26 ("Server-VLAN") über das Gateway 10.56.192.126 (IP Adresse des Switches in VLAN für Clients der ersten Organisation). Für die zweite Organisation dann das selbe nur mit deren Gateway. Dadurch sind dann die "Client-VLANs" der Organisationen getrennt.

Jetzt stehe ich allerdings noch ganz am Anfang. Habe die Einträge schon vorgenommen, scheitere aber leider schon beim Ping. Habe versucht vom CLient-VLAN eine Maschine im Server-VLAN anzupingen. Ohne Erfolg. Habe dann versucht das Gateway anzupingen, was auch nicht funktioniert hat. Ich werde aber nicht fündig wo hier der Fehler liegt.
Mein Rechner hat die IP 10.56.192.65/26 und das GW wie oben schon genannt 10.56.192.126/26. Sind also auch im selben Subnetz. Der Rechner ist auch am richtigen Port (da die VLANs ja Portbasierend sind...)
Seitenanfang Seitenende
17.07.2008, 10:03
Moderator
Avatar hevtig

Beiträge: 2298
#6

Zitat

Wieso müssen die Clients VLAN Tagging können. Das ist doch nur dazu da, damit das Gerät, das die Technik beherrscht weiß zu welchem VLAN es die empfangenen Pakete zuordnen muss...
Genau. Ich schrieb ja auch oben, daß die wenigsten Clients das können.
Wie gesagt, mit den HP Pro Curve kenne ich mich nicht so aus.
bei Cisco würdest du (müsste ich ehrlich gesagt auch nachschauen...) mE virtuelle Devices erstellen, die dann die Standardgateways spielen.
Wenn du deine Gateways nicht pingen kanst hast du evtl. keine virt. Devices erstellt?
Oder kannst du von den Switches per Konsole das GW anpingen?
__________
Woher soll ich wissen was ich denke, bevor ich höre was ich sage??
Sag NEIN zu HD+/CI+ - boykottiert die Etablierung von HD+/CI+!
Seitenanfang Seitenende