SUSE 9.0 als VPN Router wie GRE Weiterleiten

#0
17.06.2007, 16:40
Member
Avatar Xeper

Beiträge: 5289
#16 @Hotte1

Nun gut naja ich blick da immer noch nich so ganz durch tut auch nichts zu Sache hast du überhaupt was von dem was man dir vorgeschlagen hat versucht?

Zitat

Ich glaube der Lösungsansatz von heptamer666 ist schon nicht schlecht, bei der betreffenden SUSE 9.0 install fehlt jedoch das Verz. etc/protocols deshalb befürchte ich fast das die Versuche reine Zeitverschwendung sind.
Es ist kein Verzeichnis es ist eine Datei und die heißt /etc/protocols.
Und was ist denn nun mit deinem Netfilter? Schon mal nachgeschaut.
Irgendwie glaub ich du hast doch gar keine Lust das Problem zu beheben ;)
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
17.06.2007, 19:40
...neu hier

Themenstarter

Beiträge: 8
#17 Also hier einmal die iptables
iptables -A FORWARD -m state --state NEW -i eth0 -p tcp --dport 47 -j ACCEPT
iptables -A FORWARD -m state --state NEW -i eth0 -p upd --dport 47 -j ACCEPT
iptables -A FORWARD -m state --state NEW -i eth0 -p tcp --dport 1723 -j ACCEPT
iptables -A FORWARD -m state --state NEW -i eth0 -p upd --dport 1723 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -d eth0 --dport 3389 -j DNAT --to 192.168.2.251:1723
iptables -A PREROUTING -t nat -p tcp -d eth0 --dport 3389 -j DNAT --to 192.168.2.251:43
bis "Benutzername und Kennwort werden verifiziert"
geht´s dann kommt Fehler 721 "Der Remotecomputer antwortet nicht"

Danke Xeper der Tipp mit protocols als Datei war Gold wert, GRE ist dort eingetragen.
Seitenanfang Seitenende
17.06.2007, 20:48
Member
Avatar Xeper

Beiträge: 5289
#18

Zitat

iptables -A FORWARD -m state --state NEW -i eth0 -p upd --dport 47 -j ACCEPT
iptables -A FORWARD -m state --state NEW -i eth0 -p upd --dport 1723 -j ACCEPT
Heißt es nicht eher udp?
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
17.06.2007, 22:15
...neu hier

Themenstarter

Beiträge: 8
#19 Jep udp ist dann doch wohl eher richtig ;-))

Hallo HeVTig, also hinter Linux im LAN kann ich mich mit W2K3 per VPN verbinden.
Vor Linux geht´s nicht.
Im Eventlog von W2K3 kann ich diesbezüglich keine Einträge finden.
Auch die Verbindung über den Umweg Netgearrouter arbeitet einwandfrei nur das ich dann nicht mehr per FTP auf den LinuxRechner komme.
Wenn ich nicht vollkommen falsch liege müsste auf dem Linux doch nur eine Weiterleitung für PPTP mit entsprechenden Ports und Protokollen eingerichtet werden.
WAN > Linux/Router(DSL) > W2K3 Remotecomputer antwortet nicht
alles andere läuft
WAN > Netgear > W2K3 VPN läuft
Ping auf alle anderen Rechner funktioniert
Dieser Beitrag wurde am 18.06.2007 um 09:47 Uhr von Hotte1 editiert.
Seitenanfang Seitenende