Routingproblem via Router > VMware > Debianrouter > Client

#0
22.08.2006, 13:09
...neu hier

Beiträge: 2
#1 Hallo,
ich habe folg. Konstrukt:

1. einen Stinknormalen Internetrouter (192.168.2.1)
2. daran mein Windows-Laptop mit VMWare (Gateway via NAT 192.168.5.2)
3. in VWware einen Debian Server mit zwei Nics (eth1: 192.168.5.10 , eth0: 172.16.10.10)
4. dann daran via virtuellem Switch einen Ubuntu Client (172.16.10.101)

als Schaubild:

192.168.5.2 ===== eth1:192.168.5.10 = eth0:172.16.10.10 ==== eth0:172.16.10.101

Mein Problem besteht darin, dass das letzte Glied nicht auf das Internet zugreifen kann!

Habe auf dem Debianrechner folg. gemacht:
- default Gateway (eth1) & nameserver 192.168.5.2
-> Internet klappt

Auf dem Client danach:
- default Gateway & nameserver 172.16.10.10
-> Internet geht nicht

Ich muss wohl auf dem Debianrechner diverse iptables- und route-regeln erstellen, richtig? Aber welche bloß???
Seitenanfang Seitenende
22.08.2006, 14:21
Member
Avatar Xeper

Beiträge: 5289
#2

Zitat

Ich muss wohl auf dem Debianrechner diverse iptables- und route-regeln erstellen, richtig? Aber welche bloß???
Glaub ich nicht route sollte doch reichen oder?
Vielleicht brauchste forwarding mach mal:

echo 1 > /proc/sys/net/ipv4/ip_forward
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
23.08.2006, 18:21
...neu hier

Themenstarter

Beiträge: 2
#3 ip_forward hab ich auf 1

was muss ich auf dem client einstellen, bzg. gateway, nameserver und route????
Seitenanfang Seitenende
23.08.2006, 19:25
Member
Avatar Xeper

Beiträge: 5289
#4 Naja das kommt jetzt auf deine VM Einstellung an ich geh mal von Bridge aus.
Dann müßte ja die VM gateway/route der host maschine bekommen.
Und nameserver müßte der nameserver der host maschine sein.
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: