ppp0 nach eth0 mit pptp

#0
14.10.2005, 17:24
...neu hier

Beiträge: 4
#1 Hallo Leute,
ich hab ein kleines Problem mit meinem VPN.

Kurze Beschreibung


-Lokales Netz
192.168.7.50 VPN Server mit SuSE 9.3 ( pptpd )
192.168.7.20 Windows
192.168.7.100 Windows
192.168.7.1 FritzBox Fon DSL Router
INFO : Die FritzBox hat die Verbindung zum Inernet und der Port 1723 geht zum 192.1687.50 (VPN Server )

Auf dem Linux Server läuft keine Firewall !!

VPN Verbindung nach Aufbau
192.168.5.60 VPN Server SuSE mit lokaler 19.168.7.50 über ppp0
192.168.5.211 VPN Client Windows XP über ppp0

Der Aufbau der VPN Vrbindung geht einwandfrei aber dann fangen die Probleme an.
Vom Client erreiche ich folgende IP Adressen.
ping 192.168.7.50, 192.168.5.211, 192.168.5.60

Vom Server erreiche ich folgende IP Adressen
ping 192.168.7.50, 192.168.5.211, 192.168.5.60 ( und natürlich auch alle lokalen Rechner )

Das Problem was ich im mom. habe ist....
Ich habe derzeit eine Client to Server Verbindung und will eine Client to LAN haben.
Jede andere Verbindung zu einem anderen lokalen Rechner 192.168.7.20, 192.168.7.100 ist vom VPN Client nicht möglich.
Mache ich einen tcpdump auf ppp0, sehe ich, dass die icmp Anfrage kommt aber es wird nicht geantwortet.
Ich hoffe, es ist einigermassen verständlich.

Ich nehme an, dass die Informationen vom ppp0 nicht an eth0 weitergeleitet werden.
Aber wie kann ich das machen ?
Ist es vieleicht proxyarp oder bcrelay ?????
im mom. ist es egal ob ich proxyarp in der options drin hab oder nicht. Ich komme mit oder ohne proxyarp option nicht auf die lokalen Rechner.
Habe auh schon die vpn Adressen ins gleiche Netzwerk gelegt wie das lokale Netzwerk.
Hatte vorher immer die Fehlermeldung Cannot determine ethernet address for proxy ARP erhalten.
Hat aber alles nix gebracht. Ich komme nicht auf das lokale Netz.
Ich hoffe Ihr lönnt mir helfen
Danke schon mal vorab für jede Hilfe

Gruss
Gregor
Seitenanfang Seitenende
14.10.2005, 19:44
Member
Avatar Xeper

Beiträge: 5285
#2 Wie die example local.conf auf http://openvpn.net/howto.html#server schon sagt:

Zitat

# Push routes to the client to allow it
# to reach other private subnets behind
# the server. Remember that these
# private subnets will also need
# to know to route the OpenVPN client
# address pool (10.8.0.0/255.255.255.0)
# back to the OpenVPN server.
;push "route 192.168.10.0 255.255.255.0"
;push "route 192.168.20.0 255.255.255.0"
oder auch:

Zitat

# Uncomment this directive to allow different
# clients to be able to "see" each other.
# By default, clients will only see the server.
# To force clients to only see the server, you
# will also need to appropriately firewall the
# server's TUN/TAP interface.
;client-to-client
Die route auf dem client muss natürlich auch stimmen,
ich denke mal du hast da die Dokumentation nicht richtig gelesen.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
14.10.2005, 21:25
...neu hier

Themenstarter

Beiträge: 4
#3 Sorry aber ich nutze kein openvpn.
Ich habe die ganze Sache über pptpd laufen.
Sollte ich jetzt lieber openvpn nutzen ??
Aber es muss doch auch mit pptpd gehen.
Danke schon mal für deine erste Hilfe


Gruss
Gregor
Seitenanfang Seitenende
14.10.2005, 22:05
Member
Avatar Xeper

Beiträge: 5285
#4 OpenVPN ist die bessere Wahl da es sich nicht nur auf Linux beschränkt,
allerdings muss ich zu geben ich habe pptpd noch nie genutzt.
Natürlich geht das was du vor hast auch mit pptpd - wenn du weißt wie ;)
Ich weiß jedenfalls das es mit OpenVPN geht - das läuft bei mir.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
14.10.2005, 22:31
...neu hier

Themenstarter

Beiträge: 4
#5 Hmmm Du machst mir die Sache mit dem OpenVPN recht schmackhaft.
Leider habe ich jetzt schon 4 Tage an pptpd verschwendet !!!! Und ich werde jetzt nicht Aufgeben.....Erst muss ich das hier zum rennen bekommen und dann vileicht OpenVPN.

Ich hab jetzt noch ein wenig nachgelesen.
Die option proxyarp ist eigentlich dafür zuständig.
Aber ich weiss nicht warum die bei mir nicht das macht was sie soll ?
Wenn ich die option mit in die /ec/ppp/options.pptp rein nehem bekomme ich auch die Meldung das er proxyarp auf eth0 macht !

Hatte gelesen, wenn das nicht gehen soll, muss es ein Problem der Firewall sein......Grrrrrrr.....Ich hab die Firewall über den yast abgeschaltet Und die war noch nie an !!!!

Ich habs auch schon mit
arp --set <VPN Client IP> <MAC Address eth0> pub
versucht......nix, es geht einfach nicht

Na ja....dank Dir erst noch mal für deine schnelle Antwort.
Vieleicht hat ja jemand anderes da noch einen Tip

Gruss
Gregor


---------------------------------------------------------------------------
Update

Es Laeuft !!!!!!!!!
Oh mann, ich trau mich gar nicht zu sagen worann es lag !!!!!
Ich habe an alles gedacht, ich habe alles gemacht, ich habe Naechte verbracht

ABER AN DIE IP WEITERLEITUNG !!!!!!!!!! da Hab ich nicht gedacht.

Oh mann.....und das dumme ist, ich bin durch einen Zufall darauf gekommen.

Im yast koennt Ihr das bei die Netzwerkkarte und dann im Routing aktivieren ( wenn es jemand wissen will ).
Und dann gehts auch !!!!
Na ja ....zumindest habe ich einiges ber pptpd ppp und arp gelernt.
Hatt immer was gutes, wenns nicht sofort geht

Ich danke noch mal jeden, der einen Gedanken an mein Problem verschwendet hat.

Gruss
Gregor
Dieser Beitrag wurde am 15.10.2005 um 11:38 Uhr von gwichman editiert.
Seitenanfang Seitenende
16.10.2005, 15:13
Member
Avatar Xeper

Beiträge: 5285
#6

Zitat

Im yast koennt Ihr das bei die Netzwerkkarte und dann im Routing aktivieren ( wenn es jemand wissen will ).
Und dann gehts auch !!!!
Na ja ....zumindest habe ich einiges ber pptpd ppp und arp gelernt.
Hatt immer was gutes, wenns nicht sofort geht
Unglücklicherweise benutzt hier nicht jeder SuSE und möchte dies auch nicht (aus bekannten Gründen).
Das heißt der, der kein SuSE hat brauch auch kein Yast -
was meinst du also mit IP Weiterleitung, meinst du damit das forwarding im kernel?

Das schaltet man nämlich (auf 2.6) mit:
echo 1 > /proc/sys/net/ipv4/conf/all/forwarding
ein und nicht anders.

Gut das dein Fehler nichts mit pptp zu tuen hatte sondern tatsächlich nur mit routing ganz allein ;)
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
17.10.2005, 10:58
...neu hier

Themenstarter

Beiträge: 4
#7 Hi Xeper,
so wie es aussieht, wird mit dem IP Witereitung das Routing erst mal aktiviert.
Die Kiste ist dann wohl nicht mehr rein lokal.

So scheint es wohl.

Gruss
Gregor
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: