Modem finden/modem nicht finden

#0
13.08.2005, 09:38
...neu hier

Beiträge: 5
#1 ich hab Suse 9.3 und bin und neuen pc mit einer alten netzwerkkarte (RT8139D). An der Karte hängt mein Modem.
Jetzt hab ich ein Problem, was ich bis jetzt eigentlich nur von Windows kenne:
Manchmal komme ich mit dem Modem ins Internet, manchmal nicht. Bei Linux kenn ich das eigentlich, entweder ein Hardwareteil fonktioniert oder nicht (wenn nicht, kann man es fast immer zum laufen bringen, wenn man sich auskennt....)

In yast werden immer zwei konfigurierte karten erkannt:
RT8139D und ASRock vt6102
wenn das modem nicht funktioniert, muss ich beide karten löschen und wieder neu hinzufügen und neu konfigurieren. das ganze ist ja schnell geschehen, doch ist eigentlich nicht sinn der sache.

Ich habs versucht mit
System-SuSeconfig-"ENABLE-SUSECONFIG" den Wert auf "no".

auch
MODULES_LOADED_ON_BOOT="capability raw1394 video1394 8139too"
in etc/sysconfig/kernel reinzuschreiben hab ich versucht.
Doch es ist immer noch wie vorher, manchmal geht das modem, manchmal nicht.... (am modem liegts nicht!)

Weis da irgenjemand noch weiter.....?????
Liegts vielleicht an der restlichen Hardware:
ASRock K8 Upgrade VM800
Athlon 64 3000+
(sonst alles onboard)
Seitenanfang Seitenende
13.08.2005, 19:52
Member
Avatar Xeper

Beiträge: 5285
#2 Also erstmal läßt sich wohl feststellen (was ganze Zeit über nicht getan wurde) das es sich hier um ein DSL Modem handelt.
Desweiteren läßt sich feststellen das du eine Realtek NIC (RT8139D) in Betrieb hast, wofür wiederum 8139too da ist.
Ein DSL Modem wird sowieso niemals gefunden, jedenfalls nicht wenn es über RJ45 angeschloßen ist.

Da stellen sich doch folgende Fragen:
benutzt du rp-pppoe?
funktioniert die NIC?
was sagt ifconfig? (ifconfig eth0)
was sagt dmesg? (dmesg|grep eth)
ist das modul auch geladen? (lsmod|grep 8139too)
welches linux release benutzt du? (uname -r)
was sagt denn rp-pppoe? (ggf. benutzt du was anderes?)
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
13.08.2005, 21:54
...neu hier

Themenstarter

Beiträge: 5
#3 ja, war falsch geschrieben, das modem hab ich nicht gesucht, sondern ich wollte einfach nur ins internet. das geht halt über die netzwerkkarte und dem modem und dem Anschlus (kein dsl sondern ne flatrate über das tv kabel)

zu deinen fragen (soweit ich sie beantworten kann)
1 um das modem zu finden benutze ich capi-adsl (glaub ich jedenfalls...)
2 Die NIC funktioniert. (wiegesagt, manchmal komm ich ins internet, manchmal nicht. falls nicht, dann muss ich die netzwerkkarten, die im YAST als konfiguriert drinnstehen löschen und neu hinufügen, dann komm ich ins internet)
3 das modul ist geladen
4 2.6.11.4-21.2 (Suse 9.3)
5 ??

ich hab jetzt aber noch etwas anderes versucht:
ich hab im bios das onboarmodem (oder was ASRock vt6102 auch immer ist; ist glaub ich für LAN zuständig) ausgeschaltet und auch in yast rausgeschmissen. Jetzt steht als Netzwerkkarte nur noch rt 8139d drin. Das teil ASRock 6102 hab ich (glaub ich jedenfalls nicht benutzt) Bis jetzt bin ich jedesmal sofort ins internet gekommen.
Aber ist doch trotzdem komisch, das es bei linux passiert, das irgendetwas einmal funktioniert, einmal wieder nicht, ohne das was geändert wurde und es gab auch keine regelmäsigkeiten. Daher weiss ich noch nicht, ob das ganze was gebracht hat, denn wenns 3mal (sooft hab ich seit der bios änderung den pc hochgefahren) geklappt hat, heist das noch lange nicht, dass es immer funktioniert.

also drück mir die daumen, dass ich jetzt immer gleich ins netz komme. Vielleicht weist du auch, ob das ganze überhaupt sinn macht, was ich mit dem bios versucht hab.....


gruss
Seitenanfang Seitenende
13.08.2005, 22:07
Member
Avatar Xeper

Beiträge: 5285
#4

Zitat

1 um das modem zu finden benutze ich capi-adsl (glaub ich jedenfalls...)
Das hört sich sehr komisch an, du kannst das modem nicht finden über die Netzwerkkarte - das ist unmöglich. Das muss auch gar nicht von irgendwas gefunden werden?
Also wenn du dial-up hast rate ich dir mal rp-pppoe zu benutzen, alles andere macht keinen Sinn wie ich das im moment sehe.
Von capi-adsl hab ich jedenfalls auch noch nie was gehört - ich hab hier zwar zuhause normales ADSL aber ich denke mal wenn deine Geschichte auch über die NIC läuft kann es sich ja nicht so großartig unterscheiden.

Zitat

also drück mir die daumen, dass ich jetzt immer gleich ins netz komme. Vielleicht weist du auch, ob das ganze überhaupt sinn macht, was ich mit dem bios versucht hab.....
Ob du die onboard karte nun abschaltest oder anschaltest ist eigentlich egal
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
14.08.2005, 10:11
...neu hier

Themenstarter

Beiträge: 5
#5 kann auch sein, dass rp-pppoe benutzt wird, wie kann ich das denn überhaupt rausfinden?
da kenn ich mich genug aus.
Aber die verbindung zum internet wird automatisch hergestellt, denn ausser computer und modem einschalten muss ich nix machen. Browser öffene, seite aufrufen und fertig. nur manchemal wird halt keine seite geunden und ich muss netzwekkkarten löschen und wieder neu hinzufügen.
da kann doch eigentlich nur bei linux irgendwas falsch laufen. wenn die hardware nicht geändert wird und durch neukonfigurueren des systems dann doch wieder alles funktioniert????

ich kann dich verstehen, wenn du mich für blöd erklärst, dass ich irgendwie absoluten mist bau. von linux kenne ich solche zicken nicht.

also, mal schaun, wann die verbindung wieder mal nicht steht....
Seitenanfang Seitenende
14.08.2005, 14:48
Member
Avatar Xeper

Beiträge: 5285
#6

Zitat

ich kann dich verstehen, wenn du mich für blöd erklärst, dass ich irgendwie absoluten mist bau. von linux kenne ich solche zicken nicht.
Ach das nicht, nur benutzt du ein OS von dem du eigentlich keine Ahnung hast.
rp-pppoe sollte irgendwo in /etc/ppp sein, normalerweise gibts da die /etc/ppp/pppoe.conf oder sowas.
Da müßte man schon wissen was man benutzt oder was nicht, zumindestens wäre es interessant wie die debug meldungen von pppoe.conf aussehen - auch wenn du dich automatisch einwählst.
Das muss ja trozdem gestartet werden (runlevel) - logs solltest du unter /var/log finden.
Gib mal bitte den output von `ifconfig eth0` und von `cat /etc/resolv.conf` - und versuch mal herauszufinden ob du nun rp-pppoe nutzt oder nicht.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
15.08.2005, 18:09
...neu hier

Themenstarter

Beiträge: 5
#7 Hi,

also ob ich pppoe benutze oder nicht, hab ich nicht rausgebraucht.
eine pppoe.conf hab ich schon mal nicht.
das verzeichnis /etc/ppp hab ich schon länger mal durchsucht. daher bin ich auch auf capi-adsl gekommen. ich weis nicht, ob das benutzt wird, aber es gibt eine datei
/etc/capi.conf (ist aber leer:
#SuSEconfig.isdn generated
# card file proto io irq mem cardnr options)

und es gibt in /etc/ppp/peers eine datei capi-adsl:
#
# DSL connection using CAPI interface (Fritz!Card DSL)
#
plugin capiplugin.so
sync
connect ""
avmadsl
/dev/null

# Plugin passwordfd enables us to pipe the password to pppd, thus we
# don't have to put it into pap-secrets and chap-secrets.
#
plugin passwordfd.so

noauth

# pppoe has a lower mtu/mru
mtu 1492
mru 1492

# this is recommended
noccp
noipx


kann sein, dass das überhaupt nicht benutzt wird, aber das kam mit als nächste antwort auf deine frage ob ich pppoe benutze (ist vielleicht auch nur müll, was ich gedacht hab)

aber pppoe hab ich in keinem log-Verzeichnis (/var/log) gefunden (capi aber auch nicht)

nun zu den fragen, die ich sicher beantworten kann
der output von
ifconfig eth0:

eth0 Protokoll:Ethernet Hardware Adresse 00:50:FC:E6:0D:A2
inet Adresse:194.105.97.101 Bcast:194.105.97.255 Maske:255.255.255.0
inet6 Adresse: fe80::250:fcff:fee6:da2/64 Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:99847 errors:0 dropped:0 overruns:0 frame:0
TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:1000
RX bytes:6141629 (5.8 Mb) TX bytes:6757 (6.5 Kb)
Interrupt:177 Basisadresse:0xc400


cat /etc/resolv.conf
### BEGIN INFO
#
# Modified_by: dhcpcd
# Backup: /etc/resolv.conf.saved.by.dhcpcd.eth0
# Process: dhcpcd
# Process_id: 6585
# Script: /sbin/modify_resolvconf
# Saveto:
# Info: This is a temporary resolv.conf created by service dhcpcd.
# The previous file has been saved and will be restored later.
#
# If you don't like your resolv.conf to be changed, you
# can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
# variables are placed in /etc/sysconfig/network/config.
#
# You can also configure service dhcpcd not to modify it.
#
# If you don't like dhcpcd to change your nameserver
# settings
# then either set DHCLIENT_MODIFY_RESOLV_CONF=no
# in /etc/sysconfig/network/dhcp, or
# set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
# /etc/sysconfig/network/config or (manually) use dhcpcd
# with -R. If you only want to keep your searchlist, set
# DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
# (manually) use the -K option.
#
### END INFO
search cablesurf.de
nameserver 195.234.128.4
nameserver 212.20.144.98
nameserver 212.20.144.99


veilleicht wirst du dabei schauer

gruss
p.s.:
noch funktioniert die internetverbindung auf anhieb (toitoitoi)
Seitenanfang Seitenende
16.08.2005, 20:02
Member
Avatar Xeper

Beiträge: 5285
#8 Hast du kein ppp0? Also kein dial-up, was ist das Standleitung?
Geht jedenfalls anhand deiner ifconfig eth0 daraus hervor (bzw. anhand deiner Publik IP)
Naja ansonsten sieht alles okay aus, kann da nicht viel zu sagen ich kenne mich mit der Art deiner Verbindung (und mit deiner Hardware) nicht wirklich aus - sowas müßte ich analysieren.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
16.08.2005, 20:16
...neu hier

Themenstarter

Beiträge: 5
#9 Hi,

also einwählen muss ich mich nicht. mein internetanschluss geht nicht übers telefen. Ich hab ne Netrkarte, ein Modem (Motorola 5100) und das ganze ist an das TV Kabel angeschlossen. Die Internetverbindung steht, wenn das modem eingeschaltet ist (und die Netzwerkkarte funktioniert)

vielleicht hats sogar geholfen, das ich die onboardkarte deaktiviert hab, denn bis jetzt funktioniert alles. (hoffentlich noch länger)

gruss
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: