win2k zerstört debian install

#0
27.05.2004, 20:29
...neu hier

Beiträge: 1
#1 hallo leute,

edit: achja, ich möchte die debian "sarge" testing version installieren ;)

ich habe da mal ein paar fragen betreffend linux/windows2000:

also, da ich linux für mein studium brauche, will ich mir das aktuelle debian auf meinen rechner hauen. auf meiner primären platte(40gb) liegt eine windows 2000 installation mit einer fat32 partition. da diese eh schon "zugemüllt" ist und ich echt keinen nerv habe von den restlichen freien 5gb noch eine linux partition abzuspalten, habe ich mir gedacht ich krame mal meine ganz alte 1,3gb platte raus, lassse die als secondary master laufen und haue da dann das debian darauf.

so weit, so gut. es läuft auch alles wunderbar. ich habe mir die 2 bootdisks von debian runtergezogen, dann meine onboard netzwerkkarte installiert und die pakete die ich brauche. hier schonmal das erste problem: ich kann zwar von den 2 disks booten, aber dazu muss ich im bios den usb controller abschalten weil der sonst beim einlegen der 2ten dsik immer auf dem usb nach nem flash stick sucht, aber ned mehr vom lw liest. aber das jetzt nur am rande.

also, aus platzgründen installiere ich von debian nur den x-windows menupunkt und lasse den rest erstmal aussen vor. geht auch alles soweit noch. nachdem er damit fertig ist, kommt ja erstmal der reboot, ich logge mich als root ein und hole mir per apt-get noch das kde package, da ich ja auch was zum klicken und spielen haben will ;)

gut, sobald das fertig ist, muss ich ja noch den kdm holen und das xfree86 einrichten. da gehts dann auch schon los. als grakatreiber läuft bei mir nur der vesa treiber mit pci:1:0:0. da ich aber eine radeon9800xt habe, will ich natürlich diese für mein kde nutzen. hier wundern mich jetzt 2 dinge:

1) dachte durch das netinstall zieht der mir immer die aktuellesten packages runter. aber das xfree86 krieg ich nur in der version 4.3.0 (welche, wie ich gelesen habe keine radeon9800xt unterstützt). aktuell ist doch aber die version 4.4.0 (hab ich auf deren website gesehen) und die unterstützt auch die radeon 9800xt. wieso krieg ich die denn nicht? und wenn ich mir die von deren page ziehe muss ich die doch noch selbst kompilieren usw. da ich neu in linux bin hab ich KEINE ahnung wie sowas gehen soll. brauch ich die neue überhaupt oder reicht es da irgendwie einen treiber zu holen?

2) wenn ich in der xfree86 config als treiber radeon einstelle und dann startx eingebe, meckert der immer das der auf pci:1:0:1 (wenn ich auf pci:1:0:0 bin) oder auf pci 1:0:0 (wenn ich auf pci 1:0:1 bin) keinen screen findet. ja, was is denn da nun los?

gut, aber schliesslich krieg ich das kde noch noch mit vesa einstellung und einer auflösung von 1024x768 zum laufen. weiterer knackpunkt: in den display einstellungen kann ich weder auflösung noch wiederholfrequenz ändern, obwohl in der xfree86config für alle modes mindestens 4 modes angegeben sind und mein monitor die auch unterstützt. ferner steht da zwar das die wiederholfrequenz 70Hz betrage, aber das ding flimmert trotzdem so, als ob ich auf 60Hz wäre. Also wenn ich unter win2k auf 70Hz bin flimmert da nix. deswegen denke ich mal, das durch den "verkehrten" treiber gar keine 70hz zustande kommen. liege ich da richtig oder nicht? wer hat damit auch erfahrungen gemacht? (by the way: habe nen 19"er)

nun ja, also freue ich mich jetzt trotzdem das ja alles so weit "annehmbar" läuft, und schaue im internet nach wie es nun mit ati-treibern für linux aussieht. uii, da staun ich aber, es gibt ja sogar offizielle treiber. naja, schnell mal runtergezogen und geschaut. was zum teufel ist rpm? naja, schliesslich schlau geworden, alien installliert und ein deb package draus gemacht. nun kommts aber...wie installiert man denn packages die auf platte liegen? tjo, nochmal schnell in foren gewühlt und schliesslich auf den befehl "dpkg -i package.deb" gestossen. tja, aber leider geht das ned, denn er bricht immer mit der fehlermeldung ab, das er versucht ein gl-package, was ich schon habe, zu überschrieben und das ned schafft. hmm toll, und jetzt? mal geschaut ob das vielleicht schreibgeschützt is, mit "chmod 0777 *.*" mal alle rechte draufgelegt und nochmal probiert. geholfen hat das auch nix,tja pech. dann halt ned. nochmal gewühlt, bis ich irgendwo gelesen habe, das man auch sein kernel neu holen und kompilen muss und lauter anderen kram wo ich keine ahnung hab, wie das gehen soll. also bitte, HELFT MIR!! wie krieg ich denn das nun zum laufen? *verzweifel*

so, aber das beste kommt noch und DAS ist eigentlich meine hauptfrage: haben die eier in redmond (ihr wisst schon wen ich meine) eine routine eingebaut die fremde betriebssysteme zerstört???
aber mal im ernst: nachdem das alles ned so geklappt hat wie ich mir das vorgestellt habe, wollte ich den grub mal anschauen und gucken ob das win2k noch alles läuft. tjo, neu gebootet, win2k gestartet und gefreut. fein, das geht noch. nochmal n reboot gemacht zurück ins linux. aber was ist DAS??? die komplette partition war futsch und kaputt. (by the way: linux war ne ext2 partition. hat das irgendwas damit zu tun?) es fuhr hoch, aber sobald er den kernel laden wollte, hat er nix mehr gefunden. ein weiterer grund der annahme das die ganze partition hin is: wenn ich die pladde in win2k anklicke sagt der mir ned (wie er ja eigentlich sollte) platte nicht formatiert, sondern schlicht und einfach gar nix und zeigt mir nur unten an, das von 1,3gb noch ca. 935 frei sind. und jetzt denkt nicht das wäre mir erst einmal passiert. mittlerweile hab ich die 3.te install von debian hinter mir und es war immer das gleiche. es lief so weit so gut, aber sobald ich in win2k gebootet hab und danach wieder ins linux wollte war die partition futsch. wie kann denn sowas sein? mach ich da irgendwas falsch? mag windows kein debian oder was läuft da nun verkehrt? da ich mittlerweile am verzweifeln bin sag ich nur noch: BITTE HILFEE!!!!!!

auf jeden fall schonmal danke im vorraus für die antworten. wäre echt super wenn ihr mir da helfen könntet. bis dann
Dieser Beitrag wurde am 27.05.2004 um 20:38 Uhr von stolenbike editiert.
Seitenanfang Seitenende
03.06.2004, 14:25
Member
Avatar Xeper

Beiträge: 5289
#2 1) Das ist schon richtig, aktuell ist XFree version 4.4.0 aber die ist auch inkompatibel zu der GNU Lizenz. Da gabs ziemlich viel traffic drüber - aus XFree 4.4.x hat sich jedenfalls nun Xorg heraus entwickelt. Da empfehle ich dir auch dieses zu benutzen. Mehr zu dem Thema gibt es unter www.x.org - das neuste release war glaub ich 6.7.x. Zu deinem Raedeon9800xt Problem kann ich nichts sagen, kenne mich mit ATI nicht so aus. Außer das ich weiß das der support gleich null ist. Naja ich weiß aber das man readon karten auch zum laufen bekommt nur evntl. nicht problemlos wie nvidia karten.

2) s. o.

Zitat

was zum teufel ist rpm? naja, schliesslich schlau geworden, alien installliert und ein deb package draus gemacht. nun kommts aber...wie installiert man denn packages die auf platte liegen?
RPM (redhat package manager), ist der mist der jede Distribution versaut hat außer Gentoo und Debian soweit ich weiß ;)
Naja dafür hat Debian halt *.deb packete, aber wenigstens kannst du alle Packete auf www.debian.org finden.

Zitat

HELFT MIR!! wie krieg ich denn das nun zum laufen? *verzweifel*
Kenn da jemanden der hat nen Tutorial für Raedon karten geschrieben - bei Gelegenheit werde ich das hier posten.

Zitat

eine routine eingebaut die fremde betriebssysteme zerstört???
Das glaube ich eher weniger.

Zitat

hat er nix mehr gefunden. ein weiterer grund der annahme das die ganze partition hin is
Alles nur Annahmen. Ich hab scho mal GNU/Linux, windows und NetBSD alles auf einer einzigen Festplatte gehabt - und es hat funktioniert.
Am besten wäre es doch mal wenn du von beiden Festplatten einen fdisk (GNU fdisk wohlgemerkt) auszug geben könntest. Das einzige was windows ansich hat ist das es mal den MBR überschreibt wenn du es installierst. Aber das ganze Partitionen verloren gehen, ne eigentlich nicht. Aber du musst auch bedenken sonne 1.3G die ist nicht gerade die neuste HDD.
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: