Linux: local root exploit vmsplice() - >= 2.6.17

#0
14.02.2008, 18:50
Member
Avatar Xeper

Beiträge: 5289
#1 Von www.gentoo.org:

Zitat

Two major security flaws in the Linux kernel were reported last weekend. Both flaws have the same impact (root access for local users) and both exist within the vmsplice() system call, which was added to the kernel in 2.6.17. There is no configuration option to exclude vmsplice() so everyone is vulnerable.

One of the security issues existed for the entire lifetime of vmsplice(), so any kernel version from 2.6.17 onwards is vulnerable. This was fixed in 2.6.24.2, 2.6.23.16 and 2.6.22.18. It has been assigned the vulnerability identifier of CVE-2008-0600.
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0600

Also schnell updaten, insbesondere auf Servern!
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
14.02.2008, 18:54
Member

Beiträge: 896
#2 Hallo


Kernel exploit


hallo

soweit ich bei heise gelesen habe, ist im 2.6.24 die Lücke ncih ncith 100% gefixed, die Entwickler testen noch.

Ich würde mich noch nicht zu früh freuen.
__________
Mfg
schwedenmann
Seitenanfang Seitenende
15.02.2008, 11:12
Member

Beiträge: 647
#3 Seh ich als nicht so kritisch an bei Servern, die sollten eh in einem speziell geschützten Raum stehen. Ich warte daher erst noch mal ab bevor ich meine Kernels patche...
__________
Es ist nicht wenig Zeit, die wir haben, sondern viel Zeit, die wir nicht nutzen...
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: