squid und sichere Seiten (https, 443 usw.)

#0
16.08.2004, 13:05
...neu hier

Beiträge: 8
#1 Hallo, ich suche dringend Hilfe bei folgendem Problem:

Meine PC's, Proxy-Server wie auch Clients sitzen in einem Firmennetzwerk hinter einer Firewall mit einen Firmen-Proxy-Server als Tor ins Internet.
Mein interner Proxy-Server läuft auf SUSE-Linux V9.1 Prof. mit squid V2.5. Meine Clients laufen auf Windows 95, NT, 2000.

Mein Proxy-Server hat volle Internetberechtigung. D.h., mit dem Konqueror kann ich alle Seiten aufrufen, die die Clients nicht erreichen.

Mit den Clients erreiche ich alle html-Seiten und auch Script-Seiten.
Sobald einer meiner Clients auf Seiten zugreift, auf denen man Kennung und Passwort eingeben muß, erscheint nach Eingabe von Benutzerkennung und Passwort folgene Fehlermeldung: "Error The requestet URL could not be retrieved. While trying to retrieve the URL: http://signin.ebay.de/aw-cgi/eBayISAPI.dll. The following error was encountered: Connection failed. The system returned: (113) No route to host"
In der Datei access.log erscheint folgende Fehlermeldung:
1092638889.703 802 "IP-Adresse" TCP_MISS/503 1478 POST http://signin.ebay.de/aw-cgi/eBayISAPI.dll - NONE/- text.html

Bei der Postbank erscheint nach Klick auf Online-Banking: "Error The requestet URL could not be retrieved. While trying to retrieve the URL: banking.postbank.de:443. The following error was encountered: Connection failed. The system returned: (113) No route to host"
In der Datei access.log erscheint folgende Fehlermeldung:
1092654101.438 385 "IP-Adresse" TCP_MISS/503 0 CONNECT banking.postbank.de:443 - DIRECT/62.180.72.74 -

Ist squid nicht in der Lage, sichere Verbindungen aufzubauen?

Hier ein Auszug aus meiner squid.conf (nicht auskommentierte Zeilen):

http_port 4909
https_port 4909
ipc_port 0
cache_peer "Firewall-Proxy" parent 8080 7 no-query
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
cache_mem 32 MB
dns_nameservers "Intranet-Nameserver"
auth_param basic children 5
auth_param basic realm Squid proxy-caching web server
auth_param basic credentialsttl 2 hours
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern . 0 20% 4320
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl allowed_hosts src "/etc/squid/squid.allow"
http_access allow manager localhost
http_access deny manager
http_access allow allowed_hosts
http_access allow localhost
http_access deny all
http_reply_access allow all
cachemgr_passwd all
coredump_dir /var/cache/squid
deny_info TCP_RESET acl

und die Datei squid.allow

xxx.yy.13.29/255.255.255.255
xxx.yy.13.30/255.255.255.255
xxx.yy.13.38/255.255.255.255

Wer kann mir helfen?

Im voraus herzlichen Dank

Rudibert Friedhoff
Seitenanfang Seitenende
16.08.2004, 13:43
Member
Avatar Xeper

Beiträge: 5289
#2 Doch das kann er ganz gut.

Zitat

https_port 4909
dns_nameservers "Intranet-Nameserver"
Diese Zeilen mal bitte auskommentieren oder löschen.
Ansonsten kann ich eigentlich keine Fehler entdecken.

Zitat

Connection failed. The system returned: (113) No route to host"
Das ist ja auch eigentlich gar kein Squid Problem, die Fehlermeldung bekommst du dann in der Regel wenn die Maschine ihr Ziel (Internet) nicht erreichen kann.
__________
E-Mail: therion at ninth-art dot de
IRC: megatherion @ Freenode
Seitenanfang Seitenende
18.08.2004, 14:02
...neu hier

Themenstarter

Beiträge: 8
#3 Heureka ich habs.

Sollte irgend jemand mal Probleme mit dem squid hinter einer Firewall haben (z.B. mit ssl-Seiten) dann muss in der squid.conf folgendes stehen:
cache_peer "Firewall-Proxy" parent 8080 3130
never_direct allow all

Dann gehts.
Seitenanfang Seitenende
08.06.2006, 18:43
...neu hier

Beiträge: 1
#4 Hallo
vielleicht kann mir jemand helfen oder kennt wer das Problem.

Ich hab squid 2.5stable installiert, funktioniert auch ohne probs soweit.
Bis auf das Problem :
Wenn ich mich irgendwo einloggen muss , heisst User + Passwort , er schmeisst mich raus , lässt mich gernicht einloggen. heisst überall wo cookies akzeptiert werden müssen.
Firewall ist komplett deaktiviert, daran kann es nicht liegen.
hat jemand ne Idee woran es liegen könnte ?

Gruß
DynAds
Seitenanfang Seitenende
Um auf dieses Thema zu ANTWORTEN
bitte erst » hier kostenlos registrieren!!

Folgende Themen könnten Dich auch interessieren: