kann ipsec nicht mehr stoppen

#0
01.03.2006, 16:03
Member

Beiträge: 31
#1 hallo

habe debian sarge stable als ipsec gateway eingerichtet.
wenn ich ipsec einmal starte:

Code

# /etc/init.d/ipsec start
ipsec_setup: Starting FreeS/WAN IPsec 2.04...
ipsec_setup: insmod: ipsec: no module by that name found
ipsec_setup: /sbin/insmod /lib/modules/2.4.27-2-386/kernel/net/key/af_key.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/key/af_key.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/ipv4/ah4.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/ipv4/ah4.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/ipv4/esp4.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/ipv4/esp4.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/ipv4/ipcomp.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/ipv4/ipcomp.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/xfrm/xfrm_user.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/xfrm/xfrm_user.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: WARNING: setkey not found.
kann nicht mehr beenden:

Code

# /etc/init.d/ipsec stop
ipsec_setup: Stopping FreeS/WAN IPsec...
ipsec_setup: Attempt to shut Pluto down failed!  Trying kill:
ipsec_setup: /usr/lib/ipsec/_realsetup: line 1: kill: (2192) - Kein passender Prozess gefunden
und er läuft einfach weiter.
auch wenn ich process kille, startet wieder !

Code

# cat /etc/ipsec.conf

# basic configuration
config setup
    interfaces=%defaultroute
    #interfaces="ipsec0=eth0"
    klipsdebug=none
    plutodebug=none
    #plutoload=%search
    #plutostart=%search

    uniqueids=yes
    forwardcontrol=yes
    #Enable NAT-Traversal
    #nat_traversal=yes


# defaults for subsequent connection descriptions
# (these defaults will soon go away)
conn %default
    keyingtries=0
    disablearrivalcheck=no
    leftrsasigkey=%dnsondemand
    rightrsasigkey=%dnsondemand
    #compress=yes

# sample VPN connection
conn Firebox1
    authby=secret
    left=202.X.X.10
    leftnexthop=202.X.X.1
    leftsubnet=192.168.0.0/24
    right=202.X.X.10
    rightnexthop=202.X.X.1
    rightsubnet=192.168.115.0/24
    keyexchange=ike
    pfs=yes
    auto=start

conn Firebox2
    authby=secret
    left=202.X.X.10
    leftnexthop=202.X.X.1
    leftsubnet=10.0.0.0/8
    right=202.X.X.10
    rightnexthop=202.X.X.1
    rightsubnet=192.168.115.0/24
    keyexchange=ike
    pfs=yes
    auto=start

conn Firebox3
    authby=secret
    left=202.X.X.10
    leftnexthop=202.X.X.1
    leftsubnet=192.168.1.0/24
    right=202.X.X.10
    rightnexthop=202.X.X.1
    rightsubnet=192.168.115.0/24
    keyexchange=ike
    pfs=yes
    auto=start
hat jemand idee, was da falsch ist ?
Seitenanfang Seitenende
02.03.2006, 11:09
Member
Avatar Xeper

Beiträge: 5285
#2

Zitat

# /etc/init.d/ipsec start
ipsec_setup: Starting FreeS/WAN IPsec 2.04...
ipsec_setup: insmod: ipsec: no module by that name found
ipsec_setup: /sbin/insmod /lib/modules/2.4.27-2-386/kernel/net/key/af_key.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/key/af_key.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/ipv4/ah4.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/ipv4/ah4.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/ipv4/esp4.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/ipv4/esp4.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/ipv4/ipcomp.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/ipv4/ipcomp.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: /sbin/insmod -q /lib/modules/2.4.27-2-386/kernel/net/xfrm/xfrm_user.o
ipsec_setup: Using /lib/modules/2.4.27-2-386/kernel/net/xfrm/xfrm_user.o
ipsec_setup: Symbol version prefix ''
ipsec_setup: WARNING: setkey not found.
Mach mal ein ps aux|grep ipsec und paste das hier.
__________
Email/XMPP: therion at ninth-art dot de
IRC: megatherion @ Freenode
Dieser Beitrag wurde am 02.03.2006 um 11:33 Uhr von Xeper editiert.
Seitenanfang Seitenende
02.03.2006, 12:25
Member

Themenstarter

Beiträge: 31
#3 danke,
nach dem Kernel upgrade zu 2.6.8-2-686
und der ÄnderunG in /etc/ipsec.conf von:

interfaces=%defaultroute

zu:

interfaces="ipsec0=eth0"

scheint jetzt zu funktionieren

gruss
cc
Seitenanfang Seitenende